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CorelDraw Tutorials
 

CorelDRAW Tutorials: Corel Corporation's flagship graphics suite featuring CorelDRAW® and PHOTO-PAINT® provides unparalleled value and flexibility and a huge collection of fonts and clipart. These tutorials show but a fraction of the possibilities for you to explore and create. CorelDRAW is one of my most frequently used graphics applications. I can do things with CorelDRAW that simply can't be done with any other graphics program.
A PC-based graphic design vector drawing program. Files created in this program can be accepted and translated by Model Graphics if they are saved with the “.ai” extender. (see vector image)
CorelDRAW is a vector graphics editor developed and marketed by Corel Corporation of Ottawa, Canada. 
This is a popular drawing program for the Windows market. We don't support Corel Draw specifically but can usually import its files into Macromedia FreeHand or Adobe Illustrator if needed. Saving your drawings as an EPS (Encapsulated Postscript) file with all the type converted to graphics is another way we can accept this format.
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Lesson 1: The Anatomy of a Vector Illustration
Part One
Illustrations created in all major vector drawing programs have a definite anatomy and share a common pattern. Whether you use Deneba Canvas™, Adobe® Illustrator®, CorelDRAW or Macromedia® FreeHand® you will find that this pattern exists even though each program may define the parts differently. The purpose of this section of the web site is to take apart a vector drawing so you can see how it is put together and able to understand it. In the illustration section is a table of equivalent terminology to better help you translate the terms from one application to another. This will clarify the subject and make it less confusing. You will not be bound to a single application once this becomes clear to you.

The pattern of vector illustrations is best viewed or represented as a hierarchy or "tree". The illustration itself  would be at the top and its various parts would descend below it:
	An ILLUSTRATION is composed of vector

	 
	OBJECTS each having one or more

	 
	 
	PATHS which are composed of

	 
	 
	 
	LINE SEGMENTS having

	 
	 
	 
	 
	ANCHOR POINTS at each end


	 
	 

	Illustration:
	Objects:
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Paths:
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Line Segments and Anchor Points:
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In the diagram above the OBJECT shown is composed of a single closed PATH composed of 19 LINE SEGMENTS and 19 ANCHOR POINTS. Notice the curved line on the bottom. It is composed of 2 separate line segments even though it appears to be one continuous smooth line. 
Lesson 2: The Anatomy of a Vector Illustration
Part Two
Bezier Curves And The Different Kinds Of Anchor Points
Continuing with the anatomy of vector illustrations, let's now take a look at ANCHOR POINTS (or simply points or nodes...please refer to the table of equivalent terminology in the illustration section of the web site). 
Anchor Points
Anchor points are the basis of all objects in a vector illustration and are its most fundamental components. Anchor points have only a few basic properties. However, there are many combinations of these basic properties that result in several variations of anchor points. This can appear overly complex at first glance. The pattern outlined here is very simple and explains all the variations. 

All line segments have anchor points at each end which define their position and curve attributes. The name for the resulting curves are called Bezier (pronounced beh-zee-ay) curves. They are named after the French mathematician, Pierre Bezier, who developed a method for defining curves mathematically.
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All anchor points fall roughly into two categories:

1. Those having CONTROL HANDLES and
2. Those having NO CONTROL HANDLES
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Curves are controlled by control handles extending from the points. These control handles do not print. The direction and magnitude of curves entering and leaving anchor points are determined by the direction and length of the control handles.

Each control handle extending from a point controls only the portion of the curve of the line segment facing the control handle:
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Line segments with points having control handles are curved.
Line segments with points having no control handles are straight.
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Points And Control Handles
A point can have either:

1. ONE CONTROL HANDLE or
2. TWO CONTROL HANDLES

There is really only ONE handle per SIDE of a point because points between consecutive line segments are shared.
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Smooth Points And Corner Points
Points with both handles in line with each other are called SMOOTH POINTS. All other points (except for two specialized ones shown below) are generally referred to as CORNER POINTS.
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Line segments whose curves transition smoothly from one anchor point to the next in an unbroken manner are joined by smooth points.

Line segments whose curves do not transition smoothly together are joined by corner points.

The corner point shown above has two handles but a corner point can also have one handle, no handles, join a curved line segment to curved line segment, join a straight line segment to a curved line segment or a straight line segment to a straight line segment. Below are samples of corner points: 
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Specialized Points
Some point types are unique to certain applications. 

CorelDRAW has a specialized smooth point called a "symmetrical node". The lengths of both control handles of a symmetrical node remain equal when either one of them is adjusted:
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Although Deneba Canvas™ doesn't have a symmetrical point, the same effect can be produced by dragging the handle of a smooth point with Ctrl (Windows®) or Option (Mac®). When smooth points are first placed, both handles are equally spaced by default. As long as neither handle is altered, the same effect can be produced.
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Macromedia® FreeHand® 8 provides a "connector point". It is used to make a smooth transition from a straight line segment to a curved line segment. It actually controls the curve so that it is always tangent to the straight segment. The handle on this point can only move directly in line with the straight segment. You cannot alter the angle of the handle like other points. CorelDRAW also provides two similar points: either a "symmetrical line node" or "line smooth node". These points function the same as the FreeHand 8 point. This is a useful point. All draftsmen have run into this in mechanical drawing:
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Lesson 3: The Anatomy of a Vector Illustration
Part Three
Objects And Their Properties, Paths And Subpaths
Continuing with the anatomy of a vector illustration, let's take a look at objects and their properties, paths and subpaths.
Objects - Stroke and Fill Properties
Objects have stroke and fill properties. Stroke (or outline) properties apply to the path of an object and fill properties apply to the area enclosed by the path.

Stroke Properties:
    Weight (line thickness)
    Color
    Solid vs. Dashed
    Line Caps and Corners:

Except for differences in terminology, line cap and corner properties are the same between Deneba Canvas™, Adobe® Illustrator®, CorelDRAW and Macromedia® FreeHand®:
	 
	CorelDRAW
	Adobe
Illustrator
	FreeHand
	Deneba
Canvas

	 
	"Caps and 
Corners"
	"Cap and Join"
	"Cap and Join"
	"Line Joins and 
End Caps"

	Caps
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	Square
	Butt
	Butt
	Flat
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	Extended 
Square
	Projecting
	Square
	Square
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	Rounded
	Round
	Round
	Round

	Corners
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	Mitered
	Miter
	Miter
	Miter
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	Beveled
	Bevel
	Bevel
	Bevel
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	Rounded
	Round
	Round
	Round




Fill Properties:
    Color
    Uniform or Gradient Fill
    Patterns and Textures 
Stroke Examples: (fill = uniform or none) 
	Solid
	Dashed
	None
	Pattern*
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* Pattern stroke unavailable in CorelDRAW
Fill Examples: (stroke = none)
	Linear
Gradient
	Radial
Gradient
	
Pattern
	
Texture*
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* Vector texture fill available in CorelDRAW only

It could be said that Tiles are one of the basic fill properties. Patterns and tiles are basically the same kind of fill.

Deneba Canvas Stroke and Fill Examples: 

Canvas is unique in that it can apply the same properties to strokes as it can to fills. In addition to colors, textures and gradients, you can also apply symbols and hatch patterns as strokes and fills. Below are a few examples:
	
Texture Fill
	Gradient Fill
Solid Stroke
	Gradient Fill
Gradient Stroke
	
Hatch Fill
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Paths and Subpaths
Paths are either:

1. Open or
2. Closed
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Fills are not restricted to closed paths. Open paths can be filled just like closed paths:
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Paths of an object having more than one path are called subpaths.
	[image: image34.png]



	 
	Note: Subpaths are nothing more than discreet, individual paths in an object composed of more than one path. The word "subpath" is easily misunderstood because the prefix "sub" implies subordination. Multiple paths within an object are of equal hierarchy (rank).


By default each path becomes a new object when it is first created. Subpaths are created when objects are formed from composite paths.
Lesson 4: The Anatomy of a Vector Illustration
Part 3A
Composite Paths and Object Grouping and Combining
Deneba Canvas™, Adobe® Illustrator®, CorelDRAW and Macromedia® FreeHand® also share the following features...

Objects may be:

1. Grouped or
2. Formed into Composite Paths or
3. Combined into new objects

The Differences Between Composite Paths and Object Grouping And Combining
1. Object Grouping

Objects retain all their original properties and appearance when grouped. Grouping allows them to be selected with a single click and moved, resized, deleted, etc. as a single unit. Grouping has no other affect on the original appearance of the objects. Below are examples of object groups:
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2. Composite Paths

Creating a composite path from separate objects makes it possible to make doughnut-shapes and knockouts where more than one path is required. It is how the letter "O" is made. A composite path does not alter the original objects and it can be split into its original objects with a single command. Below are examples of the effect of creating composite paths out of the same objects:
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3. Combining Objects

Combining objects is a means of merging existing shapes into new shapes. With object combining, the original objects are altered. In some cases the original objects can be recreated from the new shapes by ungrouping or reapplying object combining again to these new shapes. In other cases, however, the effects of object combining is not so easily undone. Below are examples of the effect of combining objects into new shapes:
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How Each Application Defines Composite Paths and Object Grouping and Combining
Grouping and ungrouping objects, making and breaking composite paths and combining objects is supported by all four applications. The terms "group" and "ungroup" are identical between them. Composite paths and combined objects are defined differently, however: 
	Program
	Composite Paths
	Combined Objects

	CorelDRAW
	(Combining Objects)
Combine and Break Apart
	Welding, Trimming 
and Intersecting Objects

	Adobe
Illustrator
	(Compound Path)
Make and Release
	Pathfinder - Combine, Isolate 
and Subdividing Objects

	Macromedia
FreeHand
	(Composite Path)
Join and Split
	Merging Objects

	Deneba
Canvas
	(Composite Path)
Make Composite / Break Composite
	Combining Objects

	 
	 
	 


Lesson 5:The Anatomy of a Vector Illustration
Part Four - Summary
The anatomy of a vector illustration has an exact, finite pattern. There are only so many parts to it. It is summarized below:
	An ILLUSTRATION is composed of vector

	 
	OBJECTS each having one or more

	 
	 
	PATHS which are composed of

	 
	 
	 
	LINE SEGMENTS having

	 
	 
	 
	 
	ANCHOR POINTS at each end


ANCHOR POINTS fall into two categories:

1. Those having CONTROL HANDLES and
2. Those having NO CONTROL HANDLES

Line segments with points having control handles are curved.
Line segments with points having no control handles are straight.

An ANCHOR POINT can have either:

1. ONE CONTROL HANDLE or
2. TWO CONTROL HANDLES

There is really only ONE handle per SIDE of a point because points between consecutive line segments are shared.

Points with both handles in line with each other are called SMOOTH POINTS. All other points (except for the specialized ones - "symmetrical node" and "connector point") are generally referred to as CORNER POINTS.

Objects have stroke and fill properties. Stroke (or outline) properties apply to the path of an object and fill properties apply to the area enclosed by the path.

Objects may be:

1. Grouped or
2. Formed into Composite Paths or
3. Combined into new objects 

Paths are either:

1. Open or
2. Closed

That's it!

The whole purpose of this was to drive home the point that there is an anatomy to a vector illustration. It has an exact pattern. It is finite. It is simple and all vector illustrations from the simple to complex will reveal this pattern.
Lesson 6: Working With Primitives
(Predefined Shapes)
To facilitate faster construction, Deneba Canvas™, Adobe® Illustrator®, CorelDRAW and Macromedia® FreeHand® include a set of predefined object shapes or "primitives": 
	1. Rectangle (including square)
2. Ellipse (including circle) 
3. Polygon (including star)
4. Spiral
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The user can control the number of sides to polygons and stars.

All the predefined shapes can be converted to editable paths with access to the anchor points. Each program handles this slightly differently, though:

In CorelDRAW the object must first be converted to curves. 

In Macromedia FreeHand squares, rectangles, circles, ellipses and spirals must first be ungrouped while polygons and stars are editable by default. 

In Adobe Illustrator, all objects are editable by default:

In Deneba Canvas, objects are editable by default except for polygons, stars and spirals which must be converted to paths. 
	Program
	Commands

	CorelDRAW
	Arrange > Convert To Curves

	Adobe Illustrator
	(Objects are editable by default)

	Macromedia FreeHand
	Modify > Ungroup 
except for polygons and stars

	Deneba Canvas
	Object > Path > Convert To Paths
for polygons, stars and spirals only

	 
	 


Lesson 7: Keyboard Shortcuts For The Pen
	Draw Faster By Making Fewer Trips To The Tool Palette 

This tutorial is for applications that use the pen: Adobe® Photoshop®, Adobe Illustrator® and Macromedia® FreeHand®. When drawing with the pen you will inevitably have to stop mid-path and make adjustments to anchor points, control handles or line segments. 
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Note: Different software packages use different terms for the same things, and since this article is using mixed terminology please consult the table of equivalent terminology for clarification of terms.
Usually, when first learning the software, the novice will go to the tool palette to switch back and forth between the pen and other tools. This is very time consuming and there are provisions in the software to switch tools without having to select them from the tool palette. The keys on both the right-hand and left-hand sides of the spacebar are used for this purpose. Shown below are the keyboard hand positions for a right-handed mouse: 
Left hand keys - Windows®
Left hand keys - Macintosh®
Shift       =
Alt       =
Ctrl       =
        Shift
        Option
        Command
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The diagram above shows the hand positions (for a right handed mouse) to take advantage of keyboard shortcuts for drawing with the pen. This is the quickest way to use the pen. 

Mac® users will use various combinations of the Shift, Option and Command keys, while Windows users will use parallel combinations of the Shift, Ctrl and Alt keys. 

For example, while actively drawing a path with the pen tool, Windows Illustrator users can press the Ctrl key to switch between the pen and the selection tool while at the same time press the Shift key to constrain a line to 45° increments. When finished making the adjustment, the user simply releases the keys and resumes drawing with the pen tool - all without resorting to the tool palette.

Following this tutorial are step by step examples to drill the point. 


Lesson 8: Keyboard Shortcuts For The Pen Examples
The idea behind the keyboard shortcuts in Adobe® Illustrator®, Adobe Photoshop® and Macromedia® FreeHand® is so you can draw paths in a fluid manner with as few interruptions as possible. Ideally, you would draw as fluidly as if you were actually using a pen or pencil. The previous page described the hand positions with the keyboard and mouse. This page describes how it is done. The next page gives you practice templates for each application.

While the pen tool is selected and you are actively drawing a path, pressing the following keys will bring up a different tool:

For Adobe Illustrator or Adobe Photoshop:
	Macintosh®
	Windows®
	Function

	Command
Option
Shift
	Ctrl
Alt
Shift
	Selects the last selection tool
Selects the Convert Direction Point Tool
Constrains angle to 45° increments


For Macromedia FreeHand:
	Macintosh
	Windows
	Function

	Command
Option
Shift
	Ctrl
Alt
Shift
	Selects the Pointer Tool
Places a corner point
Constrains angle to 45° increments



Basically the functions of these keys between the Adobe applications and Macromedia FreeHand are the same. There is only a slight difference in the use of the Alt or Option key to create a corner point. In Illustrator and Photoshop, all newly placed points with control handles are smooth points by default. The Convert Direction Point Tool is used to change a smooth point to a corner point with handles. In FreeHand, you can drag out control handles for a corner point when you first place it. 
Brief Example - Adobe Illustrator
In the following example, three tools are used without returning to the tool palette to change tools: 
	1. Drag out the first point
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	2. Drag out the second point. The first curve is off, now.
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	3. Press Ctrl (Windows) or Command (Macintosh) and use the Direct Selection Tool to drag back the first curve.
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	4. Press Alt (Windows) or Option (Macintosh) to bring up the Convert Direction Point Tool and drag the second point's handle (changing it from a smooth point to a corner point) to redirect the next curve.
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	5. Place the next point and continue drawing the path.
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Pen Cursors

The pen cursor helps you identify where you're at when drawing paths. You need to know when you are over a point so you can append to an open path (restarting the path) or when you are over a point so you can close a path. You also need to know what the cursor looks like to start a new path so you don't inadvertently keep adding to an existing path or vice versa. These are the most important cursors. Their functions are identical between Adobe Illustrator 7 and 8, Adobe Photoshop 5 and Macromedia FreeHand 8. The chart below describes these cursors.
	 
	Start
New
Path
	Continue
Adding
To Path
	Restart
Open
Path
	Close
Path


	Illustrator 7 / 8
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	Photoshop 5
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	FreeHand 8
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Deneba Canvas™

The Curve tool is used for drawing Bezier curves in Deneba Canvas. Some of the various cursors are described below.
	 
	Add Points To Path

	Pointer Directly Over an Anchor Point. Next Click Closes Path
	Placing Straight Segments
	Placing Segments Constrained To 45°

	Deneba Canvas
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CorelDRAW®

CorelDRAW 8 handles line drawing slightly differently. You have a choice of tools. Their functions are listed below.
	 
	Freehand
Tool
Start
New
Path
	Freehand
Tool
Restart
or Close
Path
	Bezier
Tool
Start,
Continue
or Restart
Path
	Bezier
Tool
Close
Path


	CorelDRAW 8
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Lesson 9: Pen Tutorial Practice Templates
Practice Practice Practice
This page contains all the practice templates for drawing with the pen. Here are tutorials for Deneba Canvas™, Adobe® Illustrator®, Adobe Photoshop®, Macromedia® FreeHand® and CorelDRAW®. These tutorials are setup for both Macintosh® and Windows® platforms. 

You might ask, "What are Photoshop tutorials doing here in the vector application section?" Using the pen in Adobe Photoshop is virtually the same as using the pen in Adobe Illustrator. Learning pen skills really belongs here with the other vector applications. I have linked the Photoshop section of the web site to these pages for learning the pen.

These tutorials are short and fun. Make sure to download the setup sheet for the application you are using. The setup is very straightforward. Except for Photoshop (which rasterizes the PDF file...turns it into a bitmap), you simply load the tutorial PDF file into the drawing application, then lock the layer containing the template, then add a new layer and draw on that new layer. The reason you keep the template on a locked layer is because the template contains vector objects which can get selected and altered otherwise. Don't worry, it's really simple. All the instructions are in the setup sheets.

The tutorials are setup in sequence starting with the easiest ones. Each one gives you a different skill. By the time you get to the last one you will see how it all comes together. They have been purposely setup to take advantage of keyboard shortcuts so you don't have to return to the tool palette once the pen tool has been selected.

The whole point is to train you to take advantage of the keyboard shortcuts so you will draw faster, smoother and more fluidly.
Download Instructions:
Instructions:

1. First download and install the free Adobe Acrobat® Reader

2. If you wish to view the PDF file only, simply click on the link below

3. To download in Windows®: Place mouse pointer on the link, then right click the mouse.

For Internet Explorer®: "Save Target As..." 
For Netscape®: "Save Link as..." then save it to disk

4. To download in Mac®: Hold the mouse button down for a second or Control + Click and a pop up window will appear.

For Internet Explorer: "Download Link to Disk" 
For Netscape: "Save this Link as..." then save it to disk.
Lesson 10: Shortcuts And Pointers For The Pen
Pen Tips
Pen Tip No. 1

In Adobe® Illustrator®, always click the Direct Selection tool before clicking and drawing with the Pen Tool. 
	First click the Direct Selection Tool
	Then click the Pen Tool
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The reason for this is to make sure that when the Ctrl key (Windows®) is pressed (or Command key for Macintosh®), that the next selected tool is the Direct Selection Tool instead of a different, unintended selection tool. While actively making or modifying a path using the pen, pressing Ctrl (Windows) or Command (Macintosh) will activate the last selection tool used. It is more likely that you will make adjustments to anchor points and control handles while you are drawing than it is that you will move the entire path.


Pen Tip No. 2

Tear off the pen tools in Adobe Illustrator and let it float as its own palette on the workspace.
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To do this simply grab the Pen Tool button on the Tool Palette and drag it away from it. Keep it near your drawing.


Pen Tip No. 3

You can make a simulated connector point in Adobe Illustrator using the following technique:

In Illustrator 8 First, click

View > Snap To Point

This provides a means to snap points and and control handles on top of other points. This step is not necessary in Illustrator 7 because "Snap To Point" is the default.
	1. Drag the first point
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	2. Drag a second point
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	3. Click to place a third point
	[image: image75.png]




	
	 

	4. Grab the handle of the second point and drag it over the third point.
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	5. When the solid arrowhead cursor changes into a hollow one, the handle is on top of the point. Release the mouse button.
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	6. At this time you can now change the direction of the first curve going into the second point. No matter how you adjust it, there will always be a smooth transition into the straight line segment.
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	7. To reshape the curve, drag the control handle of the first point.
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	8. When the desired shape is attained, release the mouse button.
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The theory behind this tip is by laying the control handle on top of the third point (the far point in the straight line segment), it is assured that the curve going into the second point will be at a tangent to the straight segment. In Adobe Photoshop®, although there is no provision for snapping a handle over a point, you could drag a handle over a point and come close to it.


Pen Tip No. 4

Although Deneba Canvas™ doesn't have a connector point, it does have an arc tool which places both ends of an open arc so the tangents are at right angles. This makes it easy to create the same effect as a connector point.

To create this effect, first drag out an arc.
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Next double-click the arc to place it in edit mode.
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Select the point you wish to connect the tangent straight section. Either drag a marquee around it or click it.
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This is what the point looks like when it is selected.
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Next select the Curve tool. Press Ctrl-Shift (Windows) or Command-Shift (Mac) and click to place the endpoint of the straight section. The tangent line of the point that connects the straight segment to the curved segment can be pulled using Shift-Drag to constrain its movement.
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Pen Tip No. 5

Sometimes you may want a point with only one control handle. In Deneba Canvas™ 5 and 6, Macromedia® FreeHand® 8 and CorelDRAW® 8 there are provisions for making one-handled anchor points. In Adobe Illustrator, however,  you have to drag the handle over its anchor point to get rid of it:
	1. The center point has two handles. Let's get rid of one of them.
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	2. Drag a handle back into the point.
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	3. When the handle is over the point, the cursor changes from a solid arrowhead to a hollow one. Release the mouse button.
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	4. Now you have a one-handled anchor point.
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Pen Tip No. 6

Many times you will want to close an open path (Photoshop users click here for complete instructions). Sometimes it happens that you simply get lost while drawing a path and you find yourself no longer adding points to the path. To restart a path (append to a path) in Adobe Illustrator, Macromedia FreeHand or CorelDRAW, the technique is basically the same.

1. Position the pen (for CorelDRAW users the Bezier Tool or the Freehand Tool) over an end point in the path you want to restart. When you first click the tool and before positioning the cursor over the end point in the path, the cursor will appear as follows:
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	Adobe Illustrator 7 / 8
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	Adobe Photoshop 5
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	Macromedia FreeHand 8
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	CorelDRAW 8 - Freehand Tool
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	CorelDRAW 8 - Bezier Tool



2. Except for CorelDRAW while using the Bezier Tool, when you are over the point, the cursor will change to let you know that the next click will append to the path:
	[image: image95.png]



	Adobe Illustrator 7 / 8
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	Adobe Photoshop 5
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	Macromedia FreeHand 8
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	CorelDRAW 8 - Freehand Tool



3. That is your cue that the next click will append to the path. Click once to restart adding line segments to the path.

4. When you are ready to close the path simply position the cursor over the other end point of the path. When the cursor is over the point it will change to let you know that the next click will close the path:
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	Adobe Illustrator 7 / 8
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	Adobe Photoshop 5
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	Macromedia FreeHand 8
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	CorelDRAW 8 - Freehand Tool
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	CorelDRAW 8 - Bezier Tool



5. Click once to close the path.


Deneba Canvas™

With Deneba Canvas, restarting or closing an open path is very straightforward. To restart (append to) an open path, simply put the path into edit mode (double-click using the Selection tool), then select the endpoint you wish to resume adding segments to, (click to select it) then select the Curve tool and resume with the next point. When you want to close the path, when the cursor changes to a small crosshair, (below). This means the pointer is directly over an anchor point. The next click (or drag) closes the path:
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To close an open path without adding points, put the path into edit mode, then click one of the endpoints with the Curve tool. A new segment will be added joining the endpoints.


Pen Tip No. 7

Here's an undocumented tip for Deneba Canvas. Sometimes you may want to change the angle of a tangent line without changing its length. To do this, select an anchor point and position the mouse pointer just to the right or left until the cursor changes into a hollow arrowhead:
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When it does, click and drag the tangent line to change its angle...

[image: image106.png]



The angle of the handle will change, but not its length.
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Lesson 11: Shortcuts And Pointers For The Pen
Table of Equivalent Terminology
The following table shows which terms are equivalent between Deneba Canvas™, CorelDRAW®, Adobe® Illustrator® and Macromedia® FreeHand® and are presented here to sort out any possible confusion where mixed terminology has been used in this web site: 
	CorelDRAW
	Deneba
Canvas
	Adobe
Illustrator
	Macromedia
FreeHand

	
Fill
Outline
Node
Control Point
(no equivalent)
Cusp Node
Smooth Node
Symmetrical Node
Symmetrical Line Node
(or line smooth
node)
Combining Objects
Welding, Trimming and Intersecting Objects
Wireframe View
PowerClip™ 
Envelope

	
Fill
Stroke
Anchor Point
Handle
Tangent Line
Corner Point
(cusp defined as
corner point with
no handles)
Smooth Point
Smooth Point
(option/ctrl-drag handles)
(no equivalent)
Composite Path
Combining Objects
Wireframe Display
Clipping Path
Envelope

	
Fill
Stroke
Anchor Point
Direction Point
(or handle)
Direction Line
Corner Point
Smooth Point
(no equivalent)
(no equivalent)
Compound Path
Pathfinder:
Combine, Isolate
and Subdivide Objects
Artwork View
Mask
(no equivalent)

	
Fill
Stroke
Point
Point Knob
Point Handle
Corner Point
Curve Point
(no equivalent)
Connector Point
Composite Path
Merging Objects
Keyline View
Clipping Path
Envelope



 

Lesson 12: Using Masks in Illustration Programs 
 

A mask is a vector path which allows part of an object to show while blocking out the rest effectively making part of it transparent. A mask in an illustration program is functionally equivalent to a clipping path in an image editor (more).

1. Take for example a photo. You can create a mask which will knockout the background.
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2. Using the Pen, draw a path around the bird in the photo.
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3. This is a view of the path only.
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4. When the path is made into a mask and combined with the background image, the background becomes transparent.
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5. Masks can be made to create many kinds of effects. A type mask can be combined with a background photo.
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6. This is the mask created by converting type to curves.
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7. This is the type mask when combined with the background image.

[image: image115.png]Blue
Sky




Lesson 13: Porting a Masked (Cropped) Bitmap From CorelDRAW® 8
 

In CorelDRAW 8 you may have a cropped bitmap image either by importing an EPS file with an embedded clipping path (using File > Import > PostScript® Interpreted [EPS]), or by loading a bitmap image and using the node editing tools to create the cropped outline. This tutorial outlines the steps to export the cropped bitmap as a PDF file. 
	[image: image116.png]



	 
	Note: When an EPS image with a clipping path is imported into CorelDRAW, it is defined as a "cropped bitmap" where the bitmap and its mask become a single object. CorelDRAW also has a "PowerClip™" feature which is equivalent to a clipping path or mask in other drawing programs where the vector mask and bitmap image are separate objects. 


1. Launch CorelDRAW 8 and either load the cropped image or load a bitmap and use the node editing tools to create the cropped outline. This is what the image looks like in "Normal View":
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2. Click the pulldown on the toolbar to change to "Wireframe View". This will reveal the cropped outline (mask).
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	Note: At this point it would seem that the most straightforward method of creating a PDF would be to use "File > Save As" or "File > Export" and choose the PDF file type. However, it has been my experience that Adobe® Acrobat® Distiller® produces the most consistent results for this purpose.



3. Click File > Print to reveal the humongous print dialog. You need to check all the settings that can affect the masked bitmap. First select the Distiller Assistant printer driver:
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4. In the Separations tab, make sure the "Print Separations" check box is unchecked (we want a composite color output):
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5. In the PostScript tab, there is a check box for "Output color bitmaps in RGB".  In this case we want to make sure the bitmap gets printed as RGB. Also notice the check box for JPEG compression. Make sure this is not checked. The "Set flatness to:" is set to 1 in this example. This is the setting for the mask. The lower the number, the closer the mask will conform to the curves.
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6. In the Miscellaneous tab there is a whole bunch of stuff to check. In the "Special settings" section there is a scrolling box with a lot of options. Notice the one: "Print bitmaps as RGB". Next click the "Set Profiles" button up there on the right...there's no way around it...this is an Advanced tutorial. 
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7. For now let's not use any color profiles. Make sure the composite printer profile is set to "None". This relates to step 4 above. If we had wanted separations, you would check the profile for the separations printer. Click "OK" then click the "Print" button when you return to the Miscellaneous tab.
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8. FINALLY! Distiller prompts you for a filename. Enter a filename or accept the default, then click "Save".
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Lesson 14: Porting a Masked Bitmap From Macromedia® FreeHand 8®
 

You can create a masked bitmap in Macromedia FreeHand 8 by importing a bitmap then using the pen to make the mask. This tutorial outlines the steps to export the masked bitmap as a PDF file.

1. Launch FreeHand 8 and File > Import command to embed or link a bitmap image, then create the mask with the pen. This is what the image looks like with nothing selected:

[image: image126.jpg]




2. Click View > Keyline to view the mask:
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3. Click File > Output Options, then uncheck "Convert RGB to process" since this example is an RGB image. Select a flatness of 3 so the mask will conform closely to the curves.
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4. Click File > Print. In the print dialog select the Distiller® Assistant printer driver, then click the "Setup" button.
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5. In the Separations tab select "Composite".
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6. The output options (in step 3 above) are also available on the Imaging tab. Click "OK", to return to the print dialog, then click "OK" to print.

[image: image131.png]Pint setting: +IoNDRMAL [
I userrd _ |

UseiPrep fe: [Nore B

T — -

el
. Lol  Matks
™ Separation names
™ File ngme and date.
I Crop marks
T~ Registration marks

Paper Setup |

|- Imaging Dptons
& Emusion up
€ Emusion down

& Bosiive image
© Negalive image

|- Dutput Dptions
Objects: I Include invisble layers
T”_Splt complex paths

Images: [Binary (Cross Platfor)

I¥ Include QP comments

™ Conyert RGE to process.

E3 =

—

Masimum colorsteps.

Flatness

Cance

Help






7. Distiller prompts you for a filename. Enter a filename or accept the default, then click "Save".
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Lesson 15: Porting Masked Bitmaps Between Illustration Programs
 

Whereas the best format to port straight vector files is generic EPS, I have found that the most reliable format to port a bitmap image with a vector clipping path or mask is PDF (Adobe® Acrobat® Portable Document Format). There is more than one format you can use to successfully port masked bitmaps between applications but I think that the format that works most reliably and consistently between Deneba Canvas™, Adobe Illustrator®, CorelDRAW® or Macromedia® FreeHand® is PDF. 
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	Note: There is one proviso to using PDF as a means to port vector images and that is if you are using the RGB color space, you should use "Save As" or "Export" from Deneba Canvas Adobe Illustrator, CorelDRAW or Macromedia FreeHand to create the PDF file. If you use the "Print" output channel (such as when using Adobe Distiller®) all the RGB data may be converted to CMYK in the process - depending on the version of Acrobat. Refer to the Adobe technical document number 320683 at their web site:



Porting a masked bitmap involves using either File > Save As (for RGB) or File > Print (for CMYK) as an output channel. A PDF file is generated by the File > Print command where the output is sent to FILE instead of the printer. These files are then transformed into PDF format through the use of Adobe Distiller. The PDF file can then be imported into the target application where the masked bitmap will be available for editing.

Below is a chart which illustrates the use of the Portable Document Format as a means to port masked bitmaps between Deneba Canvas, Adobe Illustrator, CorelDRAW or Macromedia FreeHand: 
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Below are the step-by-step tutorials which outline exactly how this is done:


Once the masked bitmap has been ported to a PDF file, the PDF file can simply be opened in either Deneba Canvas, CorelDRAW, Adobe Illustrator or Macromedia FreeHand using the File > Open command.
Lesson 16: Moving Clipping Paths Between 
Photoshop® and Corel® PHOTO-PAINT® 8
 

Adobe® Photoshop and Corel PHOTO-PAINT 8 are two image editors with the capacity for incorporating vector paths. You may want to use both applications on a single image (Corel PHOTO-PAINT 8 creates an excellent path from a selection mask [alpha channel] with a single click). 
Exporting an image and its clipping path from Corel PHOTO-PAINT 8 to Photoshop involves first saving the path in Corel PHOTO-PAINT 8, then exporting the image as an EPS file (the EPS format is the only format where the clipping path can be exported). Adobe Illustrator® is used as a "go-between" application which will read the EPS file and allow the clipping path to be copied and pasted into Photoshop via memory. The following chart illustrates the method: 
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Moving an image with its clipping path from Photoshop to Corel PHOTO-PAINT 8 requires no special steps. Corel PHOTO-PAINT 8 will open a native Photoshop .PSD file directly and any embedded paths are accessible from within Corel PHOTO-PAINT 8.

Below are the step-by-step tutorials which outline exactly how this is done:

Moving a clipping path from Photoshop to Corel PHOTO-PAINT 8:

1. Within Corel PHOTO-PAINT, click File > Open. Load the Photoshop .PSD file with the embedded clipping path.
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2. Click the pull down next to the "WorkPath" on the tool bar or double-click the Path Node Edit Tool to bring up the Tool Settings and Click the pull down next to the "WorkPath" on it. You will see the path name of the embedded path. Click it.
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3. The path will load and it is available for editing.
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Lesson 17: Extracting Clipping Paths From Corel® PHOTO-PAINT® 8
 

There is one drawback with the way Corel PHOTO-PAINT 8 handles clipping paths. Corel PHOTO-PAINT 8 saves a path in a separate file in a proprietary format which cannot be read by either CorelDRAW® or any other application except for Corel PHOTO-PAINT. This prevents their being opened and edited directly by any other application (CorelDRAW, Deneba Canvas™, Adobe® Illustrator® or Macromedia® FreeHand®). An image can be exported as an EPS file with its clipping path. By opening this EPS file in Adobe Illustrator, the clipping path can be separated and extracted from the bitmap portion of the image. 
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	Note: Corel PHOTO-PAINT 9 now saves the path in the same file as the image.



Extracting a clipping path from Corel PHOTO-PAINT 8 involves first saving the path in Corel PHOTO-PAINT 8, then exporting the image as an EPS file (the EPS format is the only format where the clipping path can be exported). Adobe Illustrator is used as a "go-between" application which will read the EPS file and allow the clipping path to be extracted and saved in a format which can be used by other applications. The following chart illustrates the method: 
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Once the image with its clipping path has been loaded into Adobe Illustrator, the path can be extracted and saved as a separate vector file which can then be edited in CorelDRAW, Deneba Canvas, Adobe Illustrator or Macromedia FreeHand. The path also can be copied into memory within Adobe Illustrator and pasted into an Adobe Photoshop® file as a path.

Below are the step-by-step tutorials which outline exactly how this is done:
 
Lesson 18: Separating A Mask From A Cropped Bitmap In CorelDRAW®
 

When a masked bitmap is imported into CorelDRAW the bitmap and its vector mask are converted into a "cropped bitmap". A cropped bitmap is treated as a single object where the bitmap and its vector mask are inseparable when using CorelDRAW alone. There is no way to separate a vector mask from the bitmap unless you use another vector application as a "go between". If you are not importing an EPS or PDF file and intend to work with a bitmap and vector mask as separate objects, it is better to use CorelDRAW's PowerClip™ feature instead. 

If you open an EPS or PDF file with a clipping path using the File > Import > PostScript Interpreted (EPS) filter or if you embed a bitmap image and crop it with the node editing tools, you may run into this situation. Other illustration programs (Deneba Canvas™, Adobe® Illustrator® or Macromedia® FreeHand®) treat a bitmap and its mask as separate objects when imported as an EPS or PDF file. This tutorial uses one of these other applications to separate a cropped bitmap into its vector and raster components.
Extracting a mask from CorelDRAW first involves exporting the image as a PDF file (Adobe Acrobat® Portable Document Format), then using Deneba Canvas, Adobe Illustrator or Macromedia FreeHand to extract the mask from the bitmap. Any one of these programs is used as a "go-between" application which will read the PDF file and allow the mask to be extracted and saved as a vector EPS file. This vector EPS file can then be imported or opened by CorelDRAW (as well as Deneba Canvas, Adobe Illustrator or Macromedia FreeHand). The following chart illustrates the method: 
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Once the bitmap image with its mask has been loaded into Deneba Canvas, Adobe Illustrator or Macromedia FreeHand, the mask can be extracted and saved as a separate object which can then be edited in CorelDRAW or any other drawing program.

Below are the step-by-step tutorials which outline exactly how this is done:

 

 

Lesson 19: Porting Files Across Platforms:
Overview
 

I've had several requests for cross-platform tutorials. This is the first in a series of tutorials for sharing files between Macintosh® and Windows® systems. There is good news for porting files between Mac® and PC and that is that most all graphic file formats will port without any modification whatsoever. You can share files between Mac and PC versions of Adobe® Illustrator®, Adobe Photoshop®, Macromedia® FreeHand®, CorelDRAW® and Deneba Canvas™ to name a few.
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Some File Types That Port Easily Between Mac and Windows
You can share files from practically any application that is supported on both platforms. Although I am unable to do a proper test of all file formats in all systems, I have a Mac-Win network with a G4 Power Mac running OS 9 and a PC running Windows 98. On this system I've been able to successfully port the following formats without any problems:
	File Type
	Application
	Note

	PSD
AI
EPS
PDF
FH8 / FH9
CNV
PICT
GIF
JPG
PNG
TXT
DOC
HTM / HTML
FDB / ADM
QXD
	Adobe Photoshop
Adobe Illustrator
Generic EPS
Adobe Acrobat®
Macromedia FreeHand
Deneba Canvas
Macintosh PICT
GIF image
JPEG image
Macromedia Fireworks®
Notepad or SimpleText
Microsoft® Word®
Web pages
Extensis® Portfolio™
QuarkXPress™ 
	





Use .PCT extension on PC


Please keep in mind that this is a very limited list. There are many more formats which will port just as well.
You can even download files from the Internet intended for one platform using the other platform to download them. For example, it is common to download files in compressed format. You can download PC files such as .ZIP and .EXE using a Mac and port them over to the PC. These are WinZip, PKZIP (.ZIP) or EXEcutable (program) files on the PC. You also can download Macintosh .SIT and .BIN files with the PC and port them over to the Mac. These are Stuffit (.SIT) and MacBinary (.BIN) file compression formats used on the Mac (more here on these file formats).
The Macintosh and PC File Systems
The main difference between the Mac and PC file systems is that some Macintosh files have two parts called "forks" - a data fork and a resource fork. PC files have only one part. When files are ported from the Mac to the PC, the PC recognizes the data fork, but can't really do anything with the resource fork. Fortunately, most graphic file formats use the data fork.
Porting Icons and Fonts Between Mac and PC
While most application data files port without a hitch, icons and fonts are a different story. Mac icons and fonts are stored as resources. Fonts require special software and techniques for them to survive the trip (more about porting fonts here). Icons are basically images and can be converted into one of the bitmap formats then ported as data, then recreated into icons once ported. There is a lot more to the subject than can be adequately covered on this page, so it is only mentioned here.
 

Lesson 20: Two Ways To Port Files Across Platforms
 

There are basically two ways to port files between Macintosh® and Windows® platforms - over a network or by removable media (disks). The following chart best illustrates the point:
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Networking With PC MACLAN
Windows NT and Windows 2000 support the Macintosh file system and will allow connectivity to Macintosh computers over a network. However, these operating systems are more expensive and not meant for the freelance or SOHO (small office, home office) user. Most web designers and freelance artists on the PC platform use Windows 95/98. The best solution I have found for networking Macs® and PCs is PC MACLAN, from Miramar Systems, Inc. of Santa Barbara, CA:  This affordable software package is installed on a PC running Windows 95/98 and will connect a PC to a Macintosh network running AppleTalk®.
The Power Mac®
When Apple Computer introduced the Power Mac (or "PowerPC™"), new possibilities began to open up to bridge the gap between the Mac and Windows platforms. The Power Mac will read and write files on PC formatted disks and translate them into the Macintosh file system without any additional software. A Power Mac will do this right out of the box. The Windows 95/98 operating systems, unfortunately, do not read or write Macintosh formatted disks without special software. The Mac is friendlier to the PC than the PC is to the Mac for this reason.
Windows 98 Second Edition
Windows 98 SE (Second Edition) includes Internet Connection Sharing (ICS), which allows more than one computer to use a single Internet connection. Starting with Mac OS 8.5, it became possible to share this connection with a host PC running Windows 98 SE with ICS. With a single Internet connection shared by both Mac and Windows computers and by utilizing PC MACLAN, the freelance or SOHO user can harness tremendous power for a very modest investment.
Porting Files With Removable Media
Users who wish to share files between Macintosh and Windows computers who are not connected by a network can do so with removable media such as floppy diskettes or Zip® disks. A Mac can read and write to a PC-formatted disk but a PC running Windows 95/98 cannot read and write to a Mac-formatted disk without special software. If you plan to share files between a Mac and a PC, the simplest method is to use a PC-formatted diskette or Zip disk. You can read and write files to it with either the Mac or PC and the files will be readable on both platforms. But if you have a PC and you receive files on a Mac-formatted diskette or Zip disk, then you will need a special utility for the PC to be able to read and write to the Mac-formatted disk. Two popular packages for this purpose are MacOpener®, available from DataViz®, Inc. of Trumbull, CT:  and MacDrive®, available from Mediafour Corporation of West Des Moines, IA:  This type of software is only required for the PC. It is not required for the Mac.
The Internet - The Ultimate Network
The Internet has proven to be the great equalizer between users of all platforms. The Internet falls under the category of network transfer. However, in this case, no special software is required to port files across platforms. All that is required is that files be uploaded to a server, then downloaded by the user via FTP or HTTP or via email as a file attachment. Still, users must account for the differences in the Mac and PC file systems to ensure that files reach their target as intended. For example, users can't send Mac fonts to PC users without special preparation (more here). I'll cover this in more detail elsewhere in this site, but it is mentioned here as a reminder.
MacBinary, BinHex and Aladdin Stuffit®
Whereas it is possible to port files across platforms on PC-formatted removable media, another means is required to port Mac files over the Internet or to copy Mac files using a PC. In this case, Mac files have to be "flattened" using software to encode them into a one-part file by combining the two forks together. Once encoded, files can be safely copied using a PC. After porting the encoded files to a Macintosh drive they can be decoded and restored.
When Mac files are available for downloading from the Internet you will often see several file formats to choose from. The following table describes some of the most commonly used formats:
	File Extension
.BIN
.HQX
.SIT
	File Format
MacBinary 
BinHex
Aladdin Stuffit


Each of these formats flatten the two forks of the Mac file system into a single data fork which can be safely ported between the two platforms. Files encoded with these formats can be stored on Mac or PC disks. When ready to be used, they can be decoded on the Mac. The following utilities will encode and decode Mac files as described above:
MacBinary

MacBinary II+ is a freeware program available from the following link: 
http://hotfiles.zdnet.com/cgi-bin/texis/swlib/hotfiles/info.html?fcode=MC12279&b=mac 
BinHex 5.0 is a shareware program available from the following link: 
http://hotfiles.zdnet.com/cgi-bin/texis/swlib/hotfiles/info.html?fcode=MC11162&b=mac
BinHex
HQXing 1.3 is a freeware program available from the following link: 
http://hotfiles.zdnet.com/cgi-bin/texis/swlib/hotfiles/info.html?fcode=MC18910&b=mac
Aladdin Stuffit
One means of flattening Mac files is to use a file compression utility such as Stuffit, available from Aladdin Systems of Watsonville, CA: Stuffit can encode and decode files using the SIT format. The SIT (Stuffit) format on the Macintosh is equivalent to the ZIP (Winzip or PKZIP) format on the PC. Each of these formats is virtually the file compression standard for their respective platforms. Aladdin Systems offers shareware programs at their web site to encode and decode Mac files into the Stuffit format. The Aladdin Expander™ is available for the PC and The Stuffit Expander™ and DropStuff™ are available for the Macintosh. A commercial version of DropStuff is available for the PC.
The Mac shareware Stuffit Expander program will decode all of the above formats and the Mac shareware DropStuff program will encode in all formats but MacBinary.
Aladdin offers Stuffit Deluxe™ as a total solution for all of the above formats but it is strictly a commercial product. However, it is very convenient on the Mac. Stuffit Deluxe will encode and decode Mac files in all of the above formats (even the ZIP format), thus simplifying the situation by using a single application for all formats. 
 

Lesson 21: Using a Matte Color When Creating
Transparent GIFs With CorelDRAW®
 

Using a matte color for a background will help blend the edges of anti-aliased objects when making transparent GIFs. 
1. The frames used in the following animated GIF were created in CorelDRAW. The background was set to gray because the animation was to be displayed over a gray background. When each frame was exported as a transparent GIF, CorelDRAW blended the anti-alised pixels into the background color. In this fashion, the background color functioned as a matte.
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2. For each frame you export, you will see a dialog similar to the one below. When you export an image in the GIF format, select "Paletted (8-Bit)" for the color depth (underlined below). If you choose "Anti-aliasing" (circled below), CorelDRAW will blend the anti-alised pixels into the background color.
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3. If you export the frames in the GIF format, you will also see a dialog similar to the one below. In this dialog you can select the transparent color. You can use the Eyedropper (circled below) to select the color in the image preview pane. Click the Eyedropper to select the transparent color from the preview . 
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4. Using the Eyedropper, click anywhere in the background.
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5. To preview the transparency, click the "Preview" button. You can see the effect of the transparent color in the "Result" pane on the right.
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	Note: The color designated as the transparent background color is just another color in the palette. It can happen that the color you select also occurs in some of the pixels in the image itself. In this case there will be transparent voids in the image. If this occurs then pick another color for the matte - even if only similar to the color over which the image will be displayed.


6. When the exported frame is opened in an image editor, you may see the solid background color (below left). Depending on the application in which it is opened, the transparent color may appear as a checkerboard pattern (below right).
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7. To see the effect of the matte color, zoom in to see the individual anti-aliased pixels. In this case you can see that they have been blended into a gray background.
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