PhotoShop Tutorials
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Adobe® Photoshop® is the industry standard image editing program. Photoshop is a truly vast program. Photoshop is capable of so much and yet it does it all so well. Whether you prepare images for print media or the Internet, Photoshop should be included in your tool chest of graphics applications. Here are but a small sampling of Photoshop tutorials which you can do to increase your skills. 
Adobe's premier photo manipulation program. We use Photoshop to color correct and sharpen scans. Photoshop gives us the ability to make great looking reproductions of not-so-great looking photographs. After the photo is adjusted (or created) it is then imported into PageMaker or QuarkXPress. Almost all of the graphics, logos and photos on this Web site were created or modified in Photoshop.
A graphic design art and photo manipulation program using raster and vector images. Files created in this program can be accepted by Model Graphics. (see raster image, vector image)
Adobe Photoshop is a graphics editor developed and published by Adobe Systems. It is the current market leader for commercial bitmap and image manipulation, and, in addition to Adobe Acrobat, is one of the most well-known pieces of software produced by Adobe Systems. It is considered the industry standard in most, if not all, jobs related to the use of visual elements. It is usually referred to simply as "Photoshop". Photoshop is currently available for Mac OS and Microsoft Windows; versions up to Photoshop 9.0 can also be used with other operating systems such as Linux using software such as CrossOver Office. Past versions of the program were ported to the SGI IRIX platform, but official support for this port was dropped after version 3.
Lesson 1: Opening and Closing Paths In Photoshop®
1. With the Direct Selection Tool [image: image231.png]


select an anchor point. The anchor point becomes solid.
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2. Press the delete key. Both segments on either side of the selected anchor point will be deleted.
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How To Close An Open Path
Drag and Resume Method

1. With the pen tool [image: image4.png]


click and drag an anchor point of one open end. This starts adding to the path again. The pen tool changes into a black arrowhead. Release the mouse button after dragging.
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2. Position the pen tool over the anchor point at the other open end. When the small loop appears next to the pen tip, the next click closes the path.
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3. Click once to close path.
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Click and Resume Method

1. With the pen tool [image: image8.png]


click an anchor point of one open end and release the mouse button. This starts adding to the path again.
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2. Direction lines will extend from the point...
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3. Position the pen tool over the anchor point at the other open end. When the small loop appears next to the pen tip, the next click closes the path.
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4. Click once to close path.
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Lesson 2: Selecting Anchor Points and Modifying Paths In Photoshop®
Selecting All Points In A Path
1. Press and hold the Option/Alt key. With the Direct Selection Tool [image: image13.png]


click anywhere on the path. All the anchor points are selected. Selected anchor points become solid.
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Deselecting All Points In A Path

2.Using the direct selection tool, click away from the path. All points are deselected.
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Marquee Select Method

3. Using the direct selection tool drag a marquee around the path.
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4. Release the mouse button. All the anchor points are selected. Selected anchor points become solid.
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Selecting Individual Points

5. With all the anchor points now visible, use the direct selection tool to drag a marquee around the anchor points you want to select.
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6. Release the mouse button. Now only the points enclosed within the marquee are selected (and solid) and all other points become deselected (and hollow).
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Adjusting Path Segments

7. Use the direct selection tool and click and hold the mouse button on a line segment you wish to adjust
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8. Drag the line segment to the desired shape. Release the mouse button when finished.
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Lesson 3: Using Clipping Paths In Photoshop®
A clipping path is a vector path which allows part of an image to show while hiding the rest (usually its background) effectively rendering part of the image transparent. A clipping path in an image editing program is functionally equivalent to a mask in an illustration program (more).

A clipping path is a means to make parts of an image opaque and parts of an image transparent. Usually it is used to "knock out" the background. It is also a way of changing the rectangular-shaped boundary of a bitmap image into a shape of your choice. Clipping paths are made with the pen tool in Photoshop. The path itself is a vector object, while the image is a bitmap. Together, the vector path and the bitmap image can be exported as an EPS file - a file format which is capable of having both vector and bitmap data in the same image.

The resulting EPS file can be placed directly into a page layout document such as one created in QuarkXPress™ or Adobe® PageMaker®. It can also be embedded (or linked) in a vector drawing file such as one created with Adobe Illustrator®, Macromedia® FreeHand® or CorelDRAW®. The EPS file can also be distilled into a PDF file (Adobe Acrobat® Portable Document Format) with Adobe Acrobat Distiller™. In all these applications the clipping path will knock out the background of the image.

1. Let's make one. Below is a bird over a green background. Let's cut out the bird. Then we can give the bird a new background or simply place it over a plain white background. This image was chosen because the subject (the bird) is very smooth and curved making it an ideal candidate for the pen rather than the selection tools.
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2. First we use the pen to draw the path. Click the Paths tab on the Layers Palette. Then click the "New Path" icon on the bottom. The default path name for the new path is "Path 1".
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3. Draw the path with the pen. Try to place as few points as possible, adding points only when necessary. 
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4. Below is a view of the path itself.
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5. Photoshop allows more than one path to be embedded in a file. There can be only one clipping path so you have to assign which path is to be the clipping path. In the path options menu, click "Clipping Path".
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6. In the dialog choose "Path 1" to be the clipping path. The flatness value determines how closely the path conforms to the curves. The lower the number, the more closely the path will conform to the curves. Enter a value and click "OK"
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7. Next you need to save the file, then save a copy as an EPS file. Click:

File > Save

followed by...

File > Save a Copy

Choose "Photoshop EPS" as the file type, then enter a filename and click "Save".
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8. Shown below is the effect of the clipping path. The EPS file will print out like this on a PostScript® printer. To see the effect of the clipping path on screen you can open the EPS file in a drawing program (such as Adobe Illustrator, CorelDRAW or Macromedia FreeHand) or you can place the EPS file in a page layout program such as QuarkXPress or Adobe PageMaker or you can distill the EPS file with Adobe Acrobat Distiller and view the resulting PDF file in Acrobat.
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Note: If you open the EPS file in Photoshop, you won't be able to see the effect of the clipping path. To do so you either have to print it out on a PostScript® printer or view it on screen using one of the methods described above.

9. For example, you can load an image into one of the page layout or illustration programs mentioned above to function as a new background...
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10. Then you can drop the EPS image right over it.
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Lesson 4: Photoshop® Custom Textures - Part One
Obtaining Textures For Your Images
This first tutorial on the subject of textures illustrates how to take advantage of a feature in Photoshop® that allows the loading of textures via the command: 

Filter > Texture > Texturizer > Load Texture

Before you can load any textures, you have to obtain them or create them. Adobe includes several textures on the Photoshop Application CD-ROM disk. In the GOODIES folder on the CD there is a sub-folder called TEXTURES. Simply drag and drop this folder onto your hard disk. You may put it in the Photoshop application folder, but this is not required.

Textures are simply Photoshop grayscale .PSD files from which the texture information is applied with the above filter. It is not required that the image be saved in grayscale format. The texture can just as well be saved in color although Photoshop only uses the grayscale data in the file. There is an advantage to saving it in grayscale format to save disk space.

Because these texture files are simply grayscale images, this offers great flexibility in obtaining and/or cloning them. One great source for textures is Paint Shop Pro™ 5.0. If you accepted the default folders during the installation of Paint Shop Pro 5.0 on your system there will be a folder:

C:\Program Files\Paint Shop Pro 5\Papers

In this folder are paper texture files with the file extension .TEX. Open the files in Paint Shop Pro 5 and save them as .PSD files. You can then apply these textures on Photoshop images in the same manner as the ones supplied with Photoshop. 

The following background tiles were all made very rapidly in Photoshop by applying the texture filter using the "Load Texture" option. The textures were made from .PSD files using the Paint Shop Pro 5 .TEX files located in the "Papers" folder.
Background Tiles For Web Pages
	To download in Windows®:
	 

	Right click image and select "Save Image As..."

	To download in Mac®:
	 

	Drag image onto the Desktop
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The tiles were all made by duplicating a single file with a uniform color background. To make these yourself click:

File > New

Make a new 2" x 2" RGB image at 72 pixels per inch. Click the foreground color square in the color palette and set the color values to R=247, G=228 and B=186. Then click the bucket tool and flood fill the image with the new color. Save the file in JPEG format. Duplicate the file as many times as you want with the command:

Image > Duplicate

Then apply a texture to each image with the command:

Filter > Texture > Texturizer > Load Texture

Then select from the .PSD texture files on your hard disk.
Lesson 5: Photoshop® Custom Textures - Part Two
Customizing The Sandstone Texture
This second tutorial on the subject of custom textures shows how to take further advantage of the use of custom textures via the command: 

Filter > Texture > Texturizer > Load Texture

Creating a new adjusted texture from a default texture is the topic of this tutorial. You may ask, "Why would I need to adjust a default texture provided by Photoshop® ?" The images below illustrate the point: 
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Both images have the sandstone texture applied to their backgrounds. However both images have custom textures applied. The image on the left has a more coarse version of the sandstone texture and the image on the right has a finer version. Short of making your own custom textures there is only one way to accomplish the above effect:

Resample the image up then apply the default texture for a more fine appearance, or...
Resample the image down then apply the default texture for a more coarse appearance. 
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	Note: Although the filter has a "Scaling" feature which allows you to vary the coarseness of the texture, this tutorial provides a means to vary the texture outside the limits of the scaling range.


It is undesirable to resample the image, then apply the texture, then resample the image again to its original size because the image will lose data in the process. So here is how you do it.

1. For this exercise we will make two RGB images each having a resolution of 72 pixels per inch. Make one 2" x 2" and one 8" x 8":

2" x 2"
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2. Set the foreground color to a medium gray (Red=128, Green=128 and Blue=128), then flood fill both images with the medium gray foreground color. Next apply the default sandstone texture to each image:

Filter > Texture > Texturizer > Sandstone

Then select:

Scaling=100%
Relief=7
Light Direction=Top

Then Click "OK". 

3. Next duplicate the 8" x 8" image twice with the command:

Image > Duplicate

4. You now have three 8" x 8" images and one 2" x 2" image each filled with the same texture. Maintain a resolution of 72 pixels per inch and resample each image according to the following::

2" x 2" - resample to 4" x 4"...makes the coarse texture
8" x 8" - resample to 6" x 6"...makes a fine texture
8" x 8" - resample to 5" x 5"...makes a extra fine texture
8" x 8" - resample to 4" x 4"...makes an super fine texture

The finished textures are shown below: 
	Coarse
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	Fine
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Extra Fine
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Super Fine
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5. Name the image files:

SANDSTN1.PSD (Coarse)
SANDSTN2.PSD (Fine)
SANDSTN3.PSD (Extra Fine)
SANDSTN4.PSD (Super Fine)

6. To apply the new textures to an image click:

Filter > Texture > Texturizer > Load Texture

Load either SANDSTN1.PSD, SANDSTN2.PSD, SANDSTN3.PSD or SANDSTN4.PSD. You can then apply any of the filter settings as you normally would using the default sandstone texture.
Lesson 6: Photoshop® Custom Textures - Part Three
Obtaining New Textures By "Cloning"
This third tutorial on the subject of Photoshop® textures shows how to take advantage of the Texturizer Filter by "cloning" the texture qualities from one image and applying them to another.

1. The image on the left below was scanned into the computer as an RGB image. The scan was made of a common stationery "accordion file" which was selected because of the simulated leather pattern printed on it. When choosing images for textures, pick ones with a broad enough range of grayscale pixel values. This will give your textures depth and dimension. 

2. The image on the right below is was created by saving the scanned image as a new Photoshop .PSD file then converting it into a grayscale image with the command:

Image > Mode > Grayscale

It is not necessary that the image be saved in grayscale mode. But since Photoshop only uses the grayscale information in the image, it uses less disk space than a color image. You may want to do this tutorial on your own computer and use this image in your own texture library. If you are using Netscape® or Internet Explorer, simply right click on the grayscale image below and save it to disk. Then open the image in Photoshop and save it as a Photoshop .PSD file.

The new file can be stored in the same folder with other Photoshop texture files (described in a previous texture tutorial). It is this file you will be loading and applying to images with the Texturizer Filter. 
	Original Scanned Image:
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	Grayscale Image of Original Scan:
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3. Once you have saved the texture file as a grayscale Photoshop .PSD file you are ready to apply the texture to an image. Make a new RGB image at 72 pixels per inch. The image below is 256 pixels square. Click the foreground color square in the color palette and set the color values to R=199, G=159 and B=109 (it is one of the colors on the default swatches palette in Photoshop). Next click the bucket tool and flood fill the image with the foreground color.

[image: image54.png]




4. Now comes the real magic. Issue the command:

Filter > Texture > Texturizer > Load Texture

Then load the .PSD file saved in step 2 above. In this example set Scaling=100, Relief=10 and the Light Direction=Top. Click "OK" to close the dialog and apply the texture to the image.
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5. The result is a dazzling effect on a mono-colored tile that can now be used as a background or fill. You can apply this texture to any image, not just to background tiles or fills.
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Lesson 7: Tiling Textures and Fills - Part One
Giving a Texture or Fill a Uniform Appearance
Tiles are used as background images on web pages. Tiles are also used as wallpaper in Microsoft® Windows®. Pattern Fills are used in Photoshop® image editing as a means to fill an area in an image. The following guidelines should be followed in order to achieve a good result.

When making background tiles or fills, care should be taken so that...

A. The overall appearance is uniform when the image used as a background tile or fill, and...

B. The edges of the tiles mate seamlessly together.

This tutorial covers one way to achieve A above. The next tutorial addresses B. 

Making a background tile using the sandstone texture (applied with the Texturizer Filter) is very popular and is a good example of the use of this technique. 

1. Start by making a 4" x 4" RGB image at 72 pixels per inch with a white background. Save the file as TILE01.PSD or other name. Pick a color from the swatches palette that appeals to you and set it as the foreground color. By moving the mouse over the swatches, the cursor turns into an eyedropper. Simply clicking the mouse on any color swatch will set the foreground color to the one you pick.

2. Next use the bucket tool and click anywhere in the image area to flood fill it with the foreground color you selected
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3. Next apply the sandstone filter to the image with the command:

Filter > Texture > Texturizer > Sandstone

In this example set Scaling=100, Relief=4 and the Light Direction=Top. Click "OK" to close the dialog and apply the texture to the image.
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4. Make a new 4" x 4" RGB image at 72 pixels per inch with a white background. This image will only be used to test the tiling of a selected portion of the first image. It will not be saved.
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5. Click the rectangular selection tool. In the Marquee Options palette select Style=Fixed Size, Width=100 pixels, Height=100 pixels and Feather=0 pixels.
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6. Click anywhere in the image area. A 100 x 100 pixel selection marquee will appear. You will be selecting an area that will serve as a pattern that fills the second image. Since the defined pattern will simply be a tile, the trick of this technique is to select as uniform an area as possible. The goal is twofold:

a) The defined area should be as uniform as possible without any distracting flaws or unusual patterns that will repeat throughout the fill.
b) The outer edges of the defined area should mate smoothly together when they are tiled, although this is not as important as a) above because the next tutorial will explain how to overcome this.

7. Using any selection tool, click inside the selection and while pressing the mouse button, drag the marquee to a suitable location
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Once you have selected the area to define as a pattern, click:

Edit > Define Pattern

8. Next make sure the test image is the active window then click:

Edit > Fill

You will see the following dialog. Select:

Contents:
Use=Pattern

Blending:
Opacity=100%,
Mode=Normal.

Then click "OK" to apply the pattern fill to the image.

[image: image65.png][ Contents
Use: [ Patiern =

- Blending

Opecity: [T
Mode: | Normal ~

I= | reserye rensper o)






9. Now check the results of the pattern fill on the image. Look for smears, ridges, or any uneven repeating texture picked up from the pattern definition in step 7 above. If you see any undesirable repeating pattern, simply drag the selection marquee to a new location in the TILE01.PSD file and repeat the command:

Edit > Define Pattern

Repeat steps 7 and 8 as necessary until the image is filled with a smooth, even texture.
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10. Once you are satisfied with the results make the TILE01.PSD the active window and click:

Image > Crop

This will crop the image down to a 100 x 100 pixel tile.


11. Below is the finished tile. You can use it for your own backgrounds. If you are using Netscape® or Internet Explorer, simply right click on the image below and save it to disk.

[image: image68.jpg]



Lesson 8: Tiling Textures and Fills - Part Two
Making Seamless Tiles or Pattern Fills
The previous tutorial covered how to make uniform background tiles and fills. This tutorial shows how to make them mate together seamlessly. When you first create an image it doesn't necessarily mate seamlessly together when it is used as a background tile on a web page or as a pattern fill in Photoshop®. You have to edit the edges in a way that they blend together seamlessly when the image is used as a tile.

1. The way to do this is to divide the image into 4 equal sections, rearrange them, edit the edges then reassemble them into their original positions. Figure 1 below represents how an image is to be divided into 4 equal sections. Figure 2 shows how to rearrange them for editing: 
	Figure 1
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	Figure 2
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Adobe has provided the Offset filter in Photoshop which handles all the steps of dividing the image into sections, rearranging them, then reassembling them into their original positions.

2. The first most obvious requirement, then, would be to make the image with an even number of pixels in both width and height. This way you can divide the image into 4 equal sections. For this tutorial we will start by making a new RGB image 100 x 100 pixels at 72 pixels per inch. Save the new image as "GREENBK.PSD" Set the foreground color to R=73 G=125 B=128. Using the bucket tool [image: image71.png]


flood fill the image with the foreground color: 
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	Note: The images in this tutorial will be displayed twice their normal size for clarity. 
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3. Next apply the texturizer filter by clicking:

Filter > Texture > Texturizer > Sandstone

Then select:

Scaling=100%
Relief=4
Light Direction=Top

Then Click "OK". 
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4. This gives you a raw fill. It may or may not tile seamlessly.
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5. Next apply the Offset filter by clicking:

Filter > Other > Offset...

Then select:

Horizontal=50
Vertical=50

Wrap Around

Then click "OK"
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6. You can now see how the edges will mate when the image is used as a tile. The seams will show up in the horizontal and vertical centers of the image:
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7. Select the Rubber Stamp Tool [image: image78.png]


(the cloning stamp) and a small, smooth brush from the brushes palette. Next select a uniform area of the image as a source point to clone from. Then with short, quick clicks carefully blend the horizontal and vertical centers to smooth away the hard edges. Take care to avoid the outside edges of the image so as not to upset these areas when the image is reassembled:
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8. Now reapply the Offset filter by clicking Ctrl-F, or with the menu commands:

Filter > Other > Offset...

This will reverse the first application of the filter and reassemble the image into its original order:
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9. Now it would be wise to test the tile using the same technique as the previous tutorial. With GREENBK.PSD still active, click Ctrl-A to "Select All", then:

Edit > Define Pattern

Next make a new RGB image 800 x 800 pixels at 72 pixels per inch. Then click:

Edit > Fill

Select:

Contents:
Use=Pattern

Blending:
Opacity=100%,
Mode=Normal.

Then click "OK" to apply the pattern fill to the image. You will be able to see if the image tiles seamlessly or not. When you are finished with the test you can discard the new 800 x 800 image.

10. The finished background texture is shown below at normal size:
Lesson 9: Working With Layers In Photoshop®
Part One
One of Photoshop's most powerful features is the use of layers. Each layer in a Photoshop document is a separate image which can be edited apart from any other layer. A layer can be envisioned as an image on a sheet of clear material. Together, all the layers form a stack of images:
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1. Layers are managed with the Layers palette (below left). The Layers palette displays a small thumbnail view of each layer to help identify it. The appearance of a Photoshop document is a view of the layer stack from the top down (below right).
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Lesson 10: Working With Layers In Photoshop®
Part Two
2. You can turn layer visibility on and off and completely change the appearance of an image without permanently affecting a single pixel. The eye icon to the left of each layer controls its visibility. A layer is made visible or hidden by clicking its eye icon (below left). The result is the same Photoshop document shown previously with the exception that one of its layers has been hidden revealing the white background underneath. 
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3. Opt/Alt-clicking a layer's eye icon will make it visible and will hide all others (below left). In the example below, the layer named "paint" becomes the only visible layer (below right). Note that the layer named "photo" is still highlighted. The highlighted layer in the Layers palette indicates that it is the active (or selected) layer. This means that all editing in the document window will be applied to the active layer.
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4. Click a layer to activate it (circled below left). Now all editing in the document window will be applied to the "paint" layer.
Note that there is no change in the appearance of the document window (below right). Look to the Layers palette to see which layer is active, not to the document window.
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Lesson 11: Working With Layers In Photoshop®
Part Three
5. You can quickly select all opaque areas in a layer by Cmd/Ctrl-clicking the layer in the Layers palette. When you hold down the Cmd/Ctrl key, the mouse pointer turns into a hand with a square selection marquee (below left). The result will be that all the pixels in the layer will be selected. You will see a row of "marching ants" around the selected pixels in the layer (below right).
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6. To delete a layer, click it and drag it to the Trash button in the Layers palette (below left). The result is shown below right. 
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Lesson 12: Working With Layers In Photoshop®
Part Four
7. To create a new layer, click the New Layer button in the Layers palette (below left). The new layer will appear just above the active layer (below right).
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8. To duplicate a layer, drag it to the New Layer button. In the example below, a new layer will be created named "photo copy".
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9. To change the layer stacking order, click a layer and move it up or down in the Layers palette.
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Lesson 13: Working With Layers In Photoshop®
Part Five
10. You can adjust a layer's opacity by dragging the Opacity slider (below left). Alternately, you can simply enter a value for the opacity. In the example below, the shadow layer is made to appear more transparent by setting its opacity to 75% (below right).
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Layer Blending Modes
Each layer has a blending mode. A blending mode is the way layer pixels blend with the layers beneath it. The default blending mode is "Normal", but there are several to choose from. Below are just a few examples of using different blending modes on the shadow layer:
11a. Normal
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Lesson 14: Working With Layers In Photoshop®
Part Six
Layer Blending Modes Continued . . .
11b. Dissolve
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11c. Overlay
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Lesson 15: Working With Layers In Photoshop®
Part Seven
Linking Layers 
12. Layers can be linked so they can be repositioned as a unit. Click the column to the left of the layer (to the right of the layer's eye icon) to link it to the active layer (below left). In the example below, the "paint", "palette" and "shadow" layers have been linked together. When using the Move Tool and any of these layers is selected, all will move as a unit (below right).
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Lesson 16: Working With Layers In Photoshop®
Part Eight
Layers Palette Menu
The Layers palette has a menu which can be accessed by clicking the small triangle on the right side of the palette. There are several commands which are available in this menu. For example, in our sample image, we can combine the "paint" an "palette" layers with "Merge Down". 
13a. Click the paint layer to select it.
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13b. Click the small triangle on the right side of the Layers palette to access the Layers Palette Menu. Then choose "Merge Down".
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13c. The paint layer will be combined with the palette layer. The name of the layer underneath will be retained and the name of the layer on top will be discarded. In this case, the remaining name is "palette".
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Renaming a Layer
14a. To rename a layer, double-click it in the Layers palette.
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14b. Enter the new name in the dialog and click "OK" when done.
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14c. The new name will appear in the Layers palette.
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Lesson 16: Working With Layers In Photoshop®
Part Eight
Layers Palette Menu
The Layers palette has a menu which can be accessed by clicking the small triangle on the right side of the palette. There are several commands which are available in this menu. For example, in our sample image, we can combine the "paint" an "palette" layers with "Merge Down". 
13a. Click the paint layer to select it.
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13b. Click the small triangle on the right side of the Layers palette to access the Layers Palette Menu. Then choose "Merge Down".
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13c. The paint layer will be combined with the palette layer. The name of the layer underneath will be retained and the name of the layer on top will be discarded. In this case, the remaining name is "palette".
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Renaming a Layer
14a. To rename a layer, double-click it in the Layers palette.
[image: image122.png]IE

[Layers" Chamels N Fathe

Draserve Transparsncy

*

® (4[| [patette @

Pl

= Bl

B  sackaraund

=1





14b. Enter the new name in the dialog and click "OK" when done.
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14c. The new name will appear in the Layers palette.
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Lesson 18: Understanding Channel s In Photoshop®
Part Two
Storing a Selection Mask as an Alpha Channel
When you make a selection mask in Photoshop, the mask is an 8-bit grayscale image. When you save a selection in the file, Photoshop has to put it somewhere, so it is stored as a channel. 
[image: image125.png]Red Channel

Green Chamel

Blug Channel

Alpha Channel





You can try this yourself. First you need to make a selection with one or more selection tools.

4. In this example we'll use the Magic Wand Tool [image: image126.png]


and select the white background pixels. The "Anti-aliased" checkbox was checked in the Options palette. The selection marquee appears as a row of "marching ants".
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5. Now click Select > Save Selection and click OK in the dialog to save it. Photoshop will save the selection as a new channel by default.
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6. Now the Channels palette shows the new channel. Photoshop assigns the default name of "Alpha 1" to the new channel.
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7. Click the "Alpha 1" channel in the Channels palette.
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8. Now the document window will display the channel by itself.
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Lesson 19: Making a One-Pixel Brush In Photoshop®
Here's a quick and easy tip for Photoshop. Have you ever wanted to erase one pixel at a time and chose the smallest hard-edged brush, only to find that you were getting soft edges in the surrounding pixels? When you're working with really small images like icons, what you need is a one-pixel brush. It is very easy to make.
1. First, create a new image. Then use the Rectangular Marquee Tool and drag out a one-pixel square selection. 
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2. Flood fill it with black...
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3. Don't deselect anything yet...
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4. Next click the small triangle in the upper right corner of the Brushes Palette to access the options menu. Choose "Define Brush" from the menu.
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5. Photoshop adds a new brush to the palette. Double-click on the new brush to access the brush options dialog.
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6. Photoshop will anti-alias new brushes by default. Un-check the "Anti-aliased" checkbox. 
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7. To test your new brush, choose the Eraser Tool in the toolbox.
[image: image139.png]



8. I like to set my painting brush cursors to the brush size. To do this click File > Preferences > Display & Cursors and select "Brush Size" from the Painting Cursors section. Position the brush over a pixel...
[image: image140.png]O =[Jiconpsd@160.. =E1 5

DT

veooe [l

KD





9. Click to erase. It leaves no fuzzy edges.
[image: image141.png]O =[Jiconpsd@160.. =E1 5

O

DT

Te00% [iI] KD





Lesson 20: Photoshop® 4 Transparent Drop Shadow
Part One
1. First setup the image with a transparent background. Create the type layer that will have the drop shadow applied to it. This automatically inserts a new layer.
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2. In the Layers palette Ctrl-Click (Windows®) or Cmd-Click (Mac®) the mouse on the type layer. This will select all the pixels on the layer in the shape of the type. Notice the shape of the cursor [image: image143.png]


.
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3. This is what the layer looks like when selected.
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4. Click the eye icon to hide the type layer, then click the empty layer underneath to make it the active editing layer.
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5. This is what the image looks like on the empty layer with the selection.
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6. Click Select > Feather. In the dialog, enter 3 to feather the selection 3 pixels.
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7. Click Edit > Fill. Then choose Black with an Opacity of 100%, Normal mode.
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8. This is the effect of the fill command. This shadow image lies directly under the type so we need to offset it down and to the right. Before doing so, click Select > Deselect.
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There are other variations to the shadow effect. You can use Select > Expand to expand the selection, then Edit > Fill with solid black, then use Filter > Blur > Gaussian Blur.
Lesson 21: Photoshop® 4Transparent Drop Shadow
Part Two
9. In the layers palette click the eye icon on the type layer to make it visible. Then press "V" to activate the Move Tool. With the shadow layer still active click the down arrow 3 times and the right arrow 3 times.
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10. Open the background image. In this case, it is the background image of this web site (paper.gif). Press Ctrl-A (Windows®) or Cmd-A (Mac®) or click Select > All. Next click Edit > Define Pattern.
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11. Add a new layer underneath the existing two layers and make this new layer the active layer. Then click Edit > Fill and choose Use "Pattern" with an Opacity of 100%, Normal mode. Save the file.

At this point you can export it as a JPEG image. The remaining steps are to setup the image for export as a GIF.
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12. In the Layers palette Alt-Click (Windows) or Option-Click (Mac) the eye icon next to the shadow layer. This will make only the shadow layer visible. Then click the mouse on the layer to make it the active editing layer.
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13. Using the Magic Wand Tool, with a tolerance setting of 0 and no anti-aliasing, click anywhere in the transparent area where there are no pixels. This will select everything on the layer that doesn't have any pixels.
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14. In the Layers palette click the other two eye icons to make all the layers visible, then click the bottom layer to make it the active layer.
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15. Make sure the selection surrounds all the visible pixels of the type layer and its shadow (click here for why this is done).
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16. Press the Delete key to clear the excess background pixels.

[image: image158.png]shadow.psd @ 100% (Layer 2.RGB) B[]






17. Click Select > Deselect. This is what the image looks like with the excess background pixels trimmed away.

At this point you can export it as a GIF image.
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Lesson 21: Photoshop® 4Transparent Drop Shadow
Part Two
9. In the layers palette click the eye icon on the type layer to make it visible. Then press "V" to activate the Move Tool. With the shadow layer still active click the down arrow 3 times and the right arrow 3 times.
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10. Open the background image. In this case, it is the background image of this web site (paper.gif). Press Ctrl-A (Windows®) or Cmd-A (Mac®) or click Select > All. Next click Edit > Define Pattern.
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11. Add a new layer underneath the existing two layers and make this new layer the active layer. Then click Edit > Fill and choose Use "Pattern" with an Opacity of 100%, Normal mode. Save the file.

At this point you can export it as a JPEG image. The remaining steps are to setup the image for export as a GIF.
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12. In the Layers palette Alt-Click (Windows) or Option-Click (Mac) the eye icon next to the shadow layer. This will make only the shadow layer visible. Then click the mouse on the layer to make it the active editing layer.
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13. Using the Magic Wand Tool, with a tolerance setting of 0 and no anti-aliasing, click anywhere in the transparent area where there are no pixels. This will select everything on the layer that doesn't have any pixels.
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14. In the Layers palette click the other two eye icons to make all the layers visible, then click the bottom layer to make it the active layer.
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15. Make sure the selection surrounds all the visible pixels of the type layer and its shadow (click here for why this is done).
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16. Press the Delete key to clear the excess background pixels.
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17. Click Select > Deselect. This is what the image looks like with the excess background pixels trimmed away.

At this point you can export it as a GIF image.
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Lesson 23: Halo Text Effect in Photoshop®
Part Two
6. Next click Select > Feather. Enter an amount for the feather radius. In this case I chose to feather the selection 5 pixels. Click "OK" when done.
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7. We want to use this selection on Layer 1 so click this layer in the Layers palette to activate it.
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8. Click the foreground color selection box in the Toolbox (below left). This will activate the Color Picker (below center). Pick a color and click "OK" to close the dialog. In this case I picked a blue color. The foreground color selection box will now display the new foreground color (below right).
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9. Next, click Edit > Fill and choose "Foreground Color" in the dialog. Click "OK" when done.
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10. You can see the effect of the fill in the document window (below left) and as a finished image (below right).
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Lesson 24: Cool Transparent Text Effect in Photoshop® Part One 
This tutorial shows you how to create the following effect in Adobe® Photoshop:

[image: image177.jpg]




Notice that the text is defined by a black shaded area in the upper left of the text and a white shaded area in the lower right of the text. It gives an embossed look as if light is being cast from below and to the right.

This example uses a 72 ppi image with 60 point type. Accordingly, should you decide to use a higher resolution image or greater point size type you will need to adjust some of the specs. In that case I'll call out notes where applicable.

Although I used Photoshop version 5.5 for this example, both version 5.0 and 5.5 support editable text layers (text that you can change). You could do the tutorial with version 4.0, but the text won't be editable once you create it because it will be rasterized (made into pixels).

1. In this example I chose a sky image because I thought it was fitting for the effect. Load it up into Photoshop by clicking File > Open.
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2. Click anywhere on the image with the Type Tool [image: image179.png]


. In the dialog, pick an appropriate bold or black font and point size. I used 60 point Arial Black in this example. Choose "Smooth" for the Anti-Alias setting (circled below).
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3. This is what your image should look like after creating the text. Don't worry, Photoshop creates the text on a new layer so it won't affect the pixels of the background image.
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4. In the Layers palette Cmd + Click (Mac®) / Ctrl + Click (Windows®) the new layer. This will create a selection in the shape of the text. You will see the hand pointer with a square marquee when you hold down the modifier key (Cmd or Ctrl) over the layer when you click.
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5. This is what the image will look like with a selection in the shape of the text. The selection will be defined by its "marching ants" marquee.
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6. Next click Select > Save Selection.... In the dialog, just accept the defaults. When you click "OK" Photoshop will save the selection as a new channel (circled).
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Lesson 25: Cool Transparent Text Effect in Photoshop® Part Two
7. Next create two new layers. Either click the "Create new layer" icon twice (at the bottom of the Layers palette - circled below) or click Layer > New Layer... to create them. You don't need the text layer anymore so you can either hide it or delete it. In this case I chose to hide it. Just click the layer visibility icon (the icon that looks like an eye) on the far left of the text layer (circled below). The two new layers are named "Layer 1" and Layer 2".
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8. Here's what the selection looks like against the background image.
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9. Next, we want to select everything except the text, so click Select > Inverse or Cmd + Shift + I (Mac®) / Ctrl + Shift + I (Windows®).
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10. In the layers palette, temporarily hide the background image by clicking the visibility icon for the background layer (circled below). Then click one of of the new layers to make it the active layer. I chose Layer 2 (below).
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11. Click Edit > Fill. In the dialog, choose "White" from the "Use:" drop down of the Contents section. Set the opacity for 100%, Normal mode, then click "OK".
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12. This is the result of the fill. Everything except for the text shape is white.
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13. Deselect everything by clicking Select > Deselect or Cmd + D (Mac) / Ctrl + D (Windows). Then choose the Move Tool and nudge the layer 2 pixels up and 2 pixels to the left with the arrow keys.
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Lesson 26: Cool Transparent Text Effect in Photoshop® Part Three
14. We are going to use this layer to create the soft white shaded portions of the text in the lower right corner. Even though we used anti-aliasing for the text, it still needs to be a little softer. With the white layer still active, click Filter > Blur > Gaussian Blur.... In the dialog, set the blur radius to .9 pixels (circled).
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	Note: Increase the blur radius if the image resolution is greater than 72 ppi or if the size of the type is greater than 60 points. For example, if the image resolution is 144 ppi, increase the blur radius to 1.8 for 60 point type. If you chose 120 point type, then set the blur radius to 1.8  pixels for 72 ppi or 3.6  pixels for 144 ppi. 


15. Next, we want to copy only the white shaded portion of the text, so we need to load the selection that was saved in an earlier step. Click Select > Load Selection....  In the dialog click the "Channel:" drop down and choose "Alpha 1" (if you didn't give it a name when you saved it) then click "OK".
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16. The selection appears on the layer as a "marching ants" marquee in the shape of the text. When you copy the the area enclosed by the selection you will copy only the portion of the text that falls within the lower right corner of the selection. Click Edit > Copy or Cmd + C (Mac®) / Ctrl + C (Windows®). Then click Edit > Paste or Cmd + V (Mac) / Ctrl + V (Windows). This will paste a new layer into the file.
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17. Shown below is the Layers palette after executing the "Paste" command. You will see the new layer appear just over the white layer. It is named "Layer 3".
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18. Next, we need to repeat a similar series of steps for the black portion of the text shading. Start by hiding the white layer and the new one just pasted (circled below), and activate Layer 1. This was one of the two layers created in an earlier step. We want to fill this layer with black after loading and inverting the text-shaped selection.
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19. Click Select > Load Selection.... In the dialog, choose "Alpha 1" from the "Channel:" drop down as in a previous step, then click "OK". After loading the selection, click Select > Inverse to invert the selection. This will select everything except for the text shape.

[image: image198.png]Load Selection

|
Document:(LOUDSpsd__ ]

Channel:[v_Layer 2Transparency |3
|

Alpha 1

[— Operation
® New Selection
() Add to Selection
(O Subtract from Selection
(O Intersect with Selection






20. Click Edit > Fill, then select "Black" from the "Use:" drop down in the Contents section of the dialog. As before, choose 100% opacity, Normal mode. Click "OK" when done.
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21. This is what the selection looks like when filled with black. Deselect everything by clicking Select > Deselect or Cmd + D (Mac) / Ctrl + D (Windows). 
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Lesson 27: Cool Transparent Text Effect in Photoshop® Part Four
22. We need to apply the same Gaussian Blur to this black layer as we did to the white layer. In Photoshop you can repeat the previous filter by clicking Cmd + F (Mac®) / Ctrl + F (Windows®) or choose it from the top of the Filter menu (below). The settings will be exactly the same as they were for the white layer so you can use this shortcut.
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23. This will be the effect of applying the Gaussian Blur to the black layer.

[image: image202.png]T) CLOUDS psd @ 100% (Layer 1,RGB) = EI H

TEXT






24. This layer needs to be shifted down and to the right for the black shading to appear in the upper left portion of the text. Choose the Move Tool and nudge the layer down 2 pixels and to the right 2 pixels with the arrow keys.
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Remember that this tutorial is based on a 72 ppi image with 60 point type. See previous note at step 13 to compensate for a higher resolution image or a greater point size of type.

25. Once again we need to load the text-shaped selection to copy the black shaded portions of the text. Click Select > Load Selection....  In the dialog choose "Alpha 1" from the "Channel:" drop down and click "OK".
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26. The selection marquee appears on the black layer in the shape of the text. Click Edit > Copy or Cmd + C (Mac) / Ctrl + C (Windows). Then click Edit > Paste or Cmd + V (Mac) / Ctrl + V (Windows). This will paste another new layer into the file.
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27. In the Layers palette, you will see that the new layer has been pasted just over Layer 1 (the black layer). This new layer is named "Layer 4". We need to reposition this layer next to Layer 3 (the layer having the white shaded portion of the text). Then we will merge Layer 3 and layer 4 into a single layer. Start by pressing the mouse button on Layer 4.
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28. While holding the mouse button down, drag the layer upwards to position it under Layer 3.
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Lesson 28: Cool Transparent Text Effect in Photoshop® Part Five
29. Layer 4 is now positioned directly under Layer 3. Activate Layer 3 by clicking it in the Layers palette.
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30. Click the small triangle in the upper right corner of the Layers palette (circled below) to access the Layer Options menu. Choose "Merge Down" from the menu.
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31. Next, click the visibility icon to hide Layer 1 (the black layer). We are finished with it.
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32. This is the merged layer (Layer 4) that contains all the text shading. 
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33. In the Layers palette, click the visibility icon on the background layer to make it visible. Layer 4 is still the active layer, though (it is highlighted in the Layers palette).
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34. The effect is almost finished. The shaded portions of the text are still a bit harsh. The black portions are too black and the white portions are too white. We want to give it a transparent look so we can see through the shadows and highlights to the underlying image.
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35. With Layer 4 still active, click the opacity slider in the layers palette. Knock the opacity back to about 75%.
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36. This is the finished image. The text appears more transparent by adding this finishing touch.
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Lesson 29: Photo Retouching with Photoshop®
Levels Adjustment - Part 1A 
This tutorial is about one aspect of photo retouching in Photoshop - using the Levels Adjustment to correct tonal values. The Levels Adjustment function in Photoshop can be used in a variety of ways. This tutorial explores just one way. 
1. In the photo of the black bag below, the exposure looks pretty good at a glance, but because the color of this object is primarily black, it requires a little tweaking to reveal some of the detail. The Levels Adjustment will bring out the detail which is buried under the dark areas where it is difficult to see. On the right is a histogram of the image. In this tutorial, I am using Adobe® Photoshop CS. In this version the Histogram Palette is grouped with the Info and Navigator Palettes by default. The histogram is a graphic representation of the distribution of light and dark pixels. The horizontal axis represents the "darkness" of the pixels in the image - going from the darkest pixels on the left to the lightest pixels on the right. The vertical axis represents the number of pixels for each shade with the smallest number of pixels on the bottom to the largest number of pixels at the top. Please note the large clump of pixels on the left end of the histogram. This is an indication that this is a dark photo. 
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2. Now, if you had to lighten this image for print or for a web page, you may have a tendency to go straight for the "Brightness and Contrast" adjustment. Generally I will save Brightness and Contrast as my last adjustment - but not always. If you try to use Brightness and Contrast all by itself to do the job you will probably be disappointed in the results. Here's why... Go ahead and click Image > Adjustments > Brightness and Contrast (or Image > Adjust > Brightness and Contrast with older versions of Photoshop). Check the "Preview" checkbox and drag the Brightness slider to the right to lighten the image. 
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3. Now take a look at the result. You can see some more detail but the image is overexposed. It looks "washed out". Also Please note the histogram with the telltale blank area on the left side where there are no pixels represented in the dark end of the graph. This is a sure sign of an underexposed image. There were two mistakes here. Using Brightness and Contrast was only one of the mistakes. The other was using the Image > Adjustments command. You see, that command will permanently alter the pixels. Once you save and close the file, the data is gone and you can't get it back unless you have a backup copy of the image. Don't feel bad if you have done this. I messed up a whole bunch of images like this when I first began to do image editing. 
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4. Okay, let's re-open the file or click Edit > Undo, or File > Revert ... whatever it takes to get back the original image and this time we will use an Adjustment Layer. This will place a layer over the original pixels where we can make our adjustments. When we view the image we look down through this layer as if the adjustments were done to the pixels themselves. The difference is we can turn the visibility of the adjustment layer off so we don't see its effect on the pixels below it or we can throw the layer away and the pixels in the image will remain untouched. As a rule, I will always use an adjustment layer to preserve the original pixels in the image just in case I make a mistake. Click Layer > New Adjustment Layer (or Layer > New > Adjustment Layer for older versions of Photoshop). Give the layer a name or accept the default name it gives you and click the "OK" button. 
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5. You will see the the Levels dialog box and you will also see a change in the Layers Palette. You can see the new adjustment layer over the image Background Layer (or regular Layer name if it isn't the Background Layer). 
[image: image220.jpg]e [1oon [8)
Y

o | [E—

AL IR SRR




Lesson 30: Photo Retouching with Photoshop®
Levels Adjustment - Part 1B 
6. Now let's turn our attention to the Levels dialog box. As I mentioned earlier, you can use the Levels adjustment in a variety of ways. In this example, we will use the little dropper buttons in the lower right corner. Click the one on the left to set the black point. 
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7. Find the darkest area on the image and click the dropper once. 
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8. Next click the button on the right to set the white point. 
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9. Find the lightest area on the image and click the dropper once. 
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10. Finally, click the button in the middle to set the gray point. 
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Lesson 31: Photo Retouching with Photoshop®
Levels Adjustment - Part 1C
11. Find an area with the most neutral midtones in the image and click the dropper once.
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12. Next, we want to shift the midtones of the image to lighten them slightly. The center triangle at the bottom of the histogram is the gamma adjustment for the Input Levels. Dragging this triangle to the right will darken the midtones, while dragging it to the left will lighten the midtones. 
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13. Drag this triangle to the left just slightly. Make sure the Preview checkbox is checked so you can see the effect of this adjustment as you make it. After you make the adjustment, you will see a change in the center box of the Input Levels just above the histogram. 
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14. This is a view of the image after the Levels Adjustments. Also please note the histogram to the right, below and compare this with the first view of the histogram at the beginning of the tutorial before any adjustments were made. The tonal values for the pixels have been redistributed. 
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15. Below are screenshots of the image before and after the Levels Adjustments. More retouching can be done with this image but the levels Adjustment has made a big difference. You can see the detail and yet the tonal values are still in good balance. The image is neither overexposed or underexposed.
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